Back to overview
Degraded
DC Region North
Jun 12 at 06:45am CEST
Resolved
Jun 12 at 07:26am CEST
We’re back! Managed Connectivity is up and running. Thanks for bearing with us.
Affected services
Created
Jun 12 at 06:45am CEST
We’re investigating an issue with Managed Connectivity that is impacting some users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Affected services